summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2020-11-12 14:23:30 +0300
committerdefanor <defanor@uberspace.net>2020-11-12 14:23:30 +0300
commit257999ac7a08789cc421983493e43ecf5e169bab (patch)
tree5508c95777e2da46d100b21e3ccd9ef3ca8beb9a /configure.ac
parent6eabee8c7612a58695e791cb1281aae1a6c5c215 (diff)
Check server certificates using DANE (TLSA)
Currently it is just experimental and does not affect the verification (except for adding a delay); perhaps the verification should be made configurable, including an option to rely on DANE.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 942c7a3..589fd4e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,10 @@ PKG_CHECK_MODULES([GNUTLS], [gnutls])
AC_SUBST(GNUTLS_CFLAGS)
AC_SUBST(GNUTLS_LIBS)
+PKG_CHECK_MODULES([LIBDANE], [gnutls-dane])
+AC_SUBST([LIBDANE_CFLAGS])
+AC_SUBST([LIBDANE_LIBS])
+
PKG_CHECK_MODULES([GSASL], [libgsasl])
AC_SUBST(GSASL_CFLAGS)
AC_SUBST(GSASL_LIBS)