summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2021-10-13 22:03:49 +0300
committerdefanor <defanor@uberspace.net>2021-10-13 22:52:44 +0300
commit2e667698024e85fe1a9ae44181af9e38141176eb (patch)
tree0ed19b48b792fdf7f5ac14d569e5f7cd978adbd6 /configure.ac
parentf2ef0cf34d32e26c45004a5f2bd57380c15c720d (diff)
Implement Jingle RTP sessions with ICE-UDP and DTLS-SRTP
Works with Dino and Conversations, but currently relying on external players and streamers for actual audio playback and capture. For now requiring GnuTLS and libnice for calls; OpenSSL should be supported as an alternative to the former, and the latter should be made optional, maybe with libjuice as an alternative.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3e4bdd0..f2052df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,19 @@ PKG_CHECK_MODULES([LIBXML], [libxml-2.0])
AM_PATH_LIBGCRYPT
+# libnice (+ glib) and libsrtp for media calls, optional
+
+AC_ARG_ENABLE([calls], AS_HELP_STRING([--disable-calls],
+ [build without Jingle media call support]))
+
+AS_IF([test "x$enable_calls" != "xno"],
+ [PKG_CHECK_MODULES([NICE], [nice],
+ [AC_DEFINE([HAVE_NICE], [1], [libnice is available])])
+ PKG_CHECK_MODULES([GLIB], [glib-2.0],
+ [AC_DEFINE([HAVE_GLIB], [1], [glib is available])])
+ PKG_CHECK_MODULES([SRTP], [libsrtp2],
+ [AC_DEFINE([HAVE_SRTP], [1], [libsrtp2 is available])])
+ AC_DEFINE([ENABLE_CALLS], [1], [Jingle ICE-UDP DTLS-SRTP calls are enabled])])
# GSASL, optional