summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2021-02-11 16:43:47 +0300
committerdefanor <defanor@uberspace.net>2021-02-11 17:33:22 +0300
commit30b8528e17ea184a704229a82f0446b8a400ccfd (patch)
treeed9e1d1f4052f417eeec4c4d8ee4e733943cb493 /configure.ac
parent6acda7ad1f834016c9cebea0dd82467db86baeeb (diff)
Add initial JID checks
The rexmpp_jid_check function now ensures that JID parts are valid UTF-8 strings, and that only allowed code points (per RFC 8265) are used in those. Though there is a few more checks to perform still.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 02ea44c..c175e74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -38,6 +38,10 @@ AC_SUBST(UNBOUND_LIBS)
AM_PATH_GPGME
+PKG_CHECK_MODULES([ICU_I18N], [icu-i18n])
+AC_SUBST(ICU_I18N_CFLAGS)
+AC_SUBST(ICU_I18N_LIBS)
+
# Checks for header files.
AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h sys/socket.h syslog.h])