summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2023-06-18 17:38:35 +0300
committerdefanor <defanor@uberspace.net>2023-06-18 17:38:35 +0300
commitc12a24ef337889ed1f980cce2baf78ac6bd0ee93 (patch)
treeb4a5e6f08e702336057872162a26655b43e957e1 /configure.ac
parent931847c9c0d170410ec210ab558f3bbf6902355b (diff)
Duplicate most of the XML functions in Rust, use Cargo
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index e9588fa..251a94f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,7 +19,10 @@ AC_ARG_WITH([rust],
AS_IF([test "x$with_rust" == "xyes"],
[AC_PATH_PROG([RUSTC], [rustc], [notfound])
- AS_IF([test "x$RUSTC" == "xnotfound"], [AC_MSG_ERROR([rustc is required])])])
+ AS_IF([test "x$RUSTC" == "xnotfound"], [AC_MSG_ERROR([rustc is required])])
+ AC_PATH_PROG([CARGO], [cargo], [notfound])
+ AS_IF([test "x$CARGO" == "xnotfound"], [AC_MSG_ERROR([cargo is required])])
+ AC_DEFINE([USE_RUST], [1], [Use Rust sources over C ones])])
AM_CONDITIONAL([USE_RUST], [test "x$with_rust" == "xyes"])
LT_INIT