summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2023-05-04 21:29:28 +0300
committerdefanor <defanor@uberspace.net>2023-05-05 06:49:45 +0300
commitf0f947ac56f58ac5e047bdcafcdc8b9a1a1e34ee (patch)
treee742265eda45730f8656fd810d20adfb7581cd5c /configure.ac
parent938963c1d1c6a9b929d28a90030332d4f397ca61 (diff)
Introduce an alternative implementation of rexmpp_socks in Rust
Possibly other modules will follow. Aiming to provide memory-safe(r) alternatives, while keeping the C versions as well.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 26d0a76..e9588fa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -13,6 +13,15 @@ AC_CONFIG_FILES([Makefile src/Makefile tests/Makefile rexmpp.pc Doxyfile])
AC_PROG_CC
AM_PROG_AR
+AC_ARG_WITH([rust],
+ AS_HELP_STRING([--with-rust],
+ [use available Rust implementations of modules]))
+
+AS_IF([test "x$with_rust" == "xyes"],
+ [AC_PATH_PROG([RUSTC], [rustc], [notfound])
+ AS_IF([test "x$RUSTC" == "xnotfound"], [AC_MSG_ERROR([rustc is required])])])
+AM_CONDITIONAL([USE_RUST], [test "x$with_rust" == "xyes"])
+
LT_INIT
# Checks for libraries and related parameters.