summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 7 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 116598a..3e4bdd0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,11 +19,16 @@ LT_INIT
PKG_CHECK_MODULES([LIBXML], [libxml-2.0])
-PKG_CHECK_MODULES([GSASL], [libgsasl])
-
AM_PATH_LIBGCRYPT
+# GSASL, optional
+
+AC_ARG_WITH([gsasl],
+ AS_HELP_STRING([--without-gsasl], [Don't use libgsasl for SASL]))
+AS_IF([test "x$with_gsasl" != "xno"],
+ [PKG_CHECK_MODULES([GSASL], [libgsasl], [AC_DEFINE([HAVE_GSASL], [1], [GSASL is available])])])
+
# DNS: libunbound or c-ares, optional
AC_ARG_VAR([DNSSEC_TRUST_ANCHOR_FILE],