summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..6883960
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,14 @@
+AM_CFLAGS = -Werror -Wall -Wextra -Wno-pointer-sign -Wno-unused-parameter
+
+# -Wno-pointer-sign is used to suppress libxml2-related warnings.
+# Since we only care about UTF-8, and in almost all cases just its
+# ASCII subset (comparing or setting fixed namespaces, element names,
+# etc), it shouldn't matter. Later it would be nice to abstract XML
+# manipulations anyway, to allow libexpat as an alternative.
+
+lib_LTLIBRARIES = librexmpp.la
+
+librexmpp_la_SOURCES = rexmpp_tcp.h rexmpp_tcp.c rexmpp.h rexmpp.c
+include_HEADERS = rexmpp_tcp.h rexmpp.h
+librexmpp_la_CFLAGS = $(AM_CFLAGS) $(LIBXML_CFLAGS) $(GNUTLS_CFLAGS) $(GSASL_CFLAGS) $(CARES_CFLAGS)
+librexmpp_la_LIBADD = $(LIBXML_LIBS) $(GNUTLS_LIBS) $(GSASL_LIBS) $(CARES_LIBS)