summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0ccdf5b..7acc57d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,5 @@
AM_CFLAGS = -Werror -Wall -Wextra -pedantic -std=gnu99 \
- -Wno-pointer-sign \
- -Wno-stringop-truncation -Wno-stringop-overflow -Wno-maybe-uninitialized
+ -Wno-pointer-sign
# -Wno-pointer-sign is used to suppress libxml2-related warnings.
# Since we only care about UTF-8, and in almost all cases just its
@@ -8,12 +7,6 @@ AM_CFLAGS = -Werror -Wall -Wextra -pedantic -std=gnu99 \
# etc), it shouldn't matter. Later it would be nice to abstract XML
# manipulations anyway, to allow libexpat as an alternative.
-# -Wno-stringop-truncation, -Wno-stringop-overflow, and
-# -Wno-maybe-uninitialized are added because newer GCC versions
-# started complaining about the bits that are fine, though rewriting
-# those bits in a way that doesn't make GCC unhappy may be useful for
-# catching actual bugs with those warnings.
-
lib_LTLIBRARIES = librexmpp.la