summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2017-05-05 16:52:42 +0300
committerdefanor <defanor@uberspace.net>2017-05-05 17:06:31 +0300
commitca1bb0b789e954643a1f025698c8b4a1bce1450d (patch)
tree84bd41cc1127c1eafcd01aac33d3a6fab157f3ec /Makefile.am
parent14439c37cf36d9a25fc4c2023cc09d9b6ddf7ddd (diff)
Add the authenticate.sh test
The test is slow and unreliable, and should be fixed or replaced in the future. Test keys and certificates are added along with it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a64b713..7e31d9b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,7 +12,21 @@ fp2alias_CFLAGS = $(AM_CFLAGS)
std2fifo_SOURCES = std2fifo.c
std2fifo_CFLAGS = $(AM_CFLAGS)
+# tests
+
+TESTS = tests/authenticate.sh
+
+TESTS_ENVIRONMENT = \
+ builddir="$(builddir)" \
+ certdir="$(top_srcdir)/tests/"
+
+EXTRA_DIST = $(TESTS) \
+ tests/test-key-1.pem \
+ tests/test-cert-1.pem \
+ tests/test-key-2.pem \
+ tests/test-cert-2.pem
+
# docs
info_TEXINFOS = tlsd.texi
dist_man_MANS = tlsd.1 fp2alias.1 std2fifo.1
-EXTRA_DIST = examples
+EXTRA_DIST += examples