summaryrefslogtreecommitdiff
path: root/src/Cargo.toml
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2023-06-18 17:38:35 +0300
committerdefanor <defanor@uberspace.net>2023-06-18 17:38:35 +0300
commitc12a24ef337889ed1f980cce2baf78ac6bd0ee93 (patch)
treeb4a5e6f08e702336057872162a26655b43e957e1 /src/Cargo.toml
parent931847c9c0d170410ec210ab558f3bbf6902355b (diff)
Duplicate most of the XML functions in Rust, use Cargo
Diffstat (limited to 'src/Cargo.toml')
-rw-r--r--src/Cargo.toml15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Cargo.toml b/src/Cargo.toml
new file mode 100644
index 0000000..fc59bfc
--- /dev/null
+++ b/src/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "rexmpp_rust"
+version = "0.1.0"
+authors = ["defanor <defanor@uberspace.net>"]
+edition = "2018"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[lib]
+name = "rexmpp_rust"
+crate-type = ["staticlib"]
+path = "rexmpp_rust.rs"
+
+[dependencies]
+libc = "0.2"