summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2021-02-11 16:43:47 +0300
committerdefanor <defanor@uberspace.net>2021-02-11 17:33:22 +0300
commit30b8528e17ea184a704229a82f0446b8a400ccfd (patch)
treeed9e1d1f4052f417eeec4c4d8ee4e733943cb493 /src/Makefile.am
parent6acda7ad1f834016c9cebea0dd82467db86baeeb (diff)
Add initial JID checks
The rexmpp_jid_check function now ensures that JID parts are valid UTF-8 strings, and that only allowed code points (per RFC 8265) are used in those. Though there is a few more checks to perform still.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ac34f06..52d6c4a 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,5 +21,6 @@ include_HEADERS = rexmpp_roster.h rexmpp_tcp.h rexmpp_socks.h rexmpp.h \
rexmpp_dns.h rexmpp_jid.h rexmpp_openpgp.h rexmpp_console.h
librexmpp_la_CFLAGS = $(AM_CFLAGS) $(LIBXML_CFLAGS) $(GNUTLS_CFLAGS) \
$(LIBDANE_CFLAGS) $(GSASL_CFLAGS) $(UNBOUND_CFLAGS) $(GPGME_CFLAGS)
+ $(ICU_I18N_CFLAGS)
librexmpp_la_LIBADD = $(LIBXML_LIBS) $(GNUTLS_LIBS) $(LIBDANE_LIBS) \
- $(GSASL_LIBS) $(UNBOUND_LIBS) $(GPGME_LIBS)
+ $(GSASL_LIBS) $(UNBOUND_LIBS) $(GPGME_LIBS) $(ICU_I18N_LIBS)