summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2020-11-23 23:47:02 +0300
committerdefanor <defanor@uberspace.net>2020-11-23 23:47:02 +0300
commit470fda71e045f4921d93977f354a955af6a1195c (patch)
treec94b99509cd90ea77ae78ecb6483ef80422357e5 /src/Makefile.am
parentfbda87a3866678a0bf6acf09acd6f50890583be5 (diff)
Use stricter compiler checks
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 2a0dab0..ac34f06 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,4 +1,5 @@
-AM_CFLAGS = -Werror -Wall -Wextra -Wno-pointer-sign -Wno-unused-parameter
+AM_CFLAGS = -Werror -Wall -Wextra -pedantic -std=gnu99 \
+ -Wno-pointer-sign
# -Wno-pointer-sign is used to suppress libxml2-related warnings.
# Since we only care about UTF-8, and in almost all cases just its