summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2023-06-18 17:38:35 +0300
committerdefanor <defanor@uberspace.net>2023-06-18 17:38:35 +0300
commitc12a24ef337889ed1f980cce2baf78ac6bd0ee93 (patch)
treeb4a5e6f08e702336057872162a26655b43e957e1 /src/Makefile.am
parent931847c9c0d170410ec210ab558f3bbf6902355b (diff)
Duplicate most of the XML functions in Rust, use Cargo
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 0955d81..36365ea 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -40,13 +40,13 @@ librexmpp_la_LIBADD = $(LIBXML_LIBS) \
librexmpp_la_LDFLAGS = []
if USE_RUST
-librexmpp_rust_a_SOURCES = rexmpp_socks.rs
-noinst_LIBRARIES = librexmpp_rust.a
-librexmpp_la_LIBADD += librexmpp_rust.a
+target_debug_librexmpp_rust_a_SOURCES = rexmpp_rust.rs rexmpp_socks.rs rexmpp_xml.rs
+noinst_LIBRARIES = target/debug/librexmpp_rust.a
+librexmpp_la_LIBADD += target/debug/librexmpp_rust.a
librexmpp_la_LDFLAGS += -L. -lpthread -ldl
-librexmpp_rust.a: $(librexmpp_rust_a_SOURCES)
- rustc --crate-type=staticlib -o $@ $(librexmpp_rust_a_SOURCES)
+target/debug/librexmpp_rust.a: $(target_debug_librexmpp_rust_a_SOURCES)
+ $(CARGO) build
else
librexmpp_la_SOURCES += rexmpp_socks.h rexmpp_socks.c