summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index c0c7073..de0a68f 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -44,9 +44,7 @@ noinst_LIBRARIES = librexmpp_rust.a
librexmpp_la_LIBADD += librexmpp_rust.a
librexmpp_la_LDFLAGS += -L. -lpthread -ldl
-# todo: setup it properly, to rebuild whenever the sources are
-# changed.
-librexmpp_rust.a:
+librexmpp_rust.a: $(librexmpp_rust_a_SOURCES)
rustc --crate-type=staticlib -o $@ $(librexmpp_rust_a_SOURCES)
else