summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordefanor <defanor@uberspace.net>2020-11-13 14:40:11 +0300
committerdefanor <defanor@uberspace.net>2020-11-13 14:40:11 +0300
commit3749774b44405f7cdafcd3bb13c7ecbcf34a2f26 (patch)
treea702921107ddb73126f31d63a9974daa9a35ef21 /configure.ac
parent257999ac7a08789cc421983493e43ecf5e169bab (diff)
Switch from c-ares to libunbound
libunbound supports DNSSEC, which is needed for DANE TLSA: GnuTLS verifies a certificate for the final host, but SRV and A/AAAA records leading to it should be verified as well. c-ares is still used to parse domain names in SRV records, but should be replaced soon.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 589fd4e..8fd21d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,9 @@ PKG_CHECK_MODULES([CARES], [libcares])
AC_SUBST(CARES_CFLAGS)
AC_SUBST(CARES_LIBS)
+PKG_CHECK_MODULES([UNBOUND], [libunbound])
+AC_SUBST(UNBOUND_CFLAGS)
+AC_SUBST(UNBOUND_LIBS)
# Checks for header files.
AC_CHECK_HEADERS([arpa/inet.h netdb.h netinet/in.h sys/socket.h syslog.h])